summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake4
1 files changed, 2 insertions, 2 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 44725edc8..fdf1e20f8 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -165,13 +165,13 @@ Default BBFILES are the .bb files in the current directory.""")
bb.utils.init_logger(bb.msg, configuration.verbose, configuration.debug,
configuration.debug_domains)
- cooker = bb.cooker.BBCooker(configuration, server)
-
# Clear away any spurious environment variables. But don't wipe the
# environment totally. This is necessary to ensure the correct operation
# of the UIs (e.g. for DISPLAY, etc.)
bb.utils.clean_environment()
+ cooker = bb.cooker.BBCooker(configuration, server)
+
cooker.parseCommandLine()
serverinfo = server.BitbakeServerInfo(cooker.server)