aboutsummaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake3
1 files changed, 1 insertions, 2 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 4adb6d740..482b71ffc 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -637,8 +637,6 @@ class BBCooker:
self.parseConfigurationFile( os.path.join( "conf", "bitbake.conf" ) )
- bb.data.update_data( make.cfg )
-
if not bb.data.getVar("BUILDNAME", make.cfg):
bb.data.setVar("BUILDNAME", os.popen('date +%Y%m%d%H%M').readline().strip(), make.cfg)
@@ -696,6 +694,7 @@ class BBCooker:
print "Requested parsing .bb files only. Exiting."
return
+ bb.data.update_data( make.cfg )
self.buildDepgraph()
if make.options.show_versions: