summaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake3
1 files changed, 2 insertions, 1 deletions
diff --git a/bin/bitbake b/bin/bitbake
index fdeeb36a4..56f39f8ef 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -190,7 +190,7 @@ Default BBFILES are the .bb files in the current directory.""")
# server is daemonized this logfile will be truncated.
cooker_logfile = os.path.join(os.getcwd(), "cooker.log")
- bb.utils.init_logger(bb.msg, configuration.verbose, configuration.debug,
+ bb.msg.init_msgconfig(configuration.verbose, configuration.debug,
configuration.debug_domains)
# Ensure logging messages get sent to the UI as events
@@ -228,6 +228,7 @@ Default BBFILES are the .bb files in the current directory.""")
try:
return server.launchUI(ui_main, server_connection.connection, server_connection.events)
finally:
+ bb.event.ui_queue = []
server_connection.terminate()
return 1