summaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake6
1 files changed, 1 insertions, 5 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 7caa5d95e..846172a48 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -198,11 +198,7 @@ Default BBFILES are the .bb files in the current directory.""")
print("FATAL: Invalid user interface '%s' specified. " % ui)
print("Valid interfaces are 'ncurses', 'depexp' or the default, 'knotty'.")
else:
- try:
- return_value = ui_init(serverConnection.connection, serverConnection.events)
- except Exception as e:
- print("FATAL: Unable to start to '%s' UI: %s" % (ui, e))
- raise
+ return_value = ui_init(serverConnection.connection, serverConnection.events)
finally:
serverConnection.terminate()