aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ChangeLog2
-rw-r--r--lib/bb/cache.py2
-rw-r--r--lib/bb/cooker.py1
3 files changed, 4 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index 4a437a372..83f602e49 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -147,6 +147,8 @@ Changes in Bitbake 1.9.x:
- Raise an exception if SRCREV == 'INVALID'
- Fix hg fetcher username/password handling and fix crash
- Fix PACKAGES_DYNAMIC handling of packages with '++' in the name
+ - Rename __depends to __base_depends after configuration parsing so we don't
+ recheck the validity of the config files time after time
Changes in Bitbake 1.8.0:
- Release 1.7.x as a stable series
diff --git a/lib/bb/cache.py b/lib/bb/cache.py
index bcf393a57..fe38ea0ae 100644
--- a/lib/bb/cache.py
+++ b/lib/bb/cache.py
@@ -39,7 +39,7 @@ except ImportError:
import pickle
bb.msg.note(1, bb.msg.domain.Cache, "Importing cPickle failed. Falling back to a very slow implementation.")
-__cache_version__ = "128"
+__cache_version__ = "129"
class Cache:
"""
diff --git a/lib/bb/cooker.py b/lib/bb/cooker.py
index c92ad70a2..8eb1a410f 100644
--- a/lib/bb/cooker.py
+++ b/lib/bb/cooker.py
@@ -758,6 +758,7 @@ class BBCooker:
self.handleCollections( bb.data.getVar("BBFILE_COLLECTIONS", self.configuration.data, 1) )
bb.msg.debug(1, bb.msg.domain.Collection, "collecting .bb files")
+ bb.data.renameVar("__depends", "__base_depends", self.configuration.data)
(filelist, masked) = self.collect_bbfiles()
self.parse_bbfiles(filelist, masked)
bb.msg.debug(1, bb.msg.domain.Collection, "parsing complete")