summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--TODO1
-rwxr-xr-xbin/bitbake3
-rw-r--r--lib/bb/cooker.py3
3 files changed, 1 insertions, 6 deletions
diff --git a/TODO b/TODO
index 8bfaf0ed4..b42113360 100644
--- a/TODO
+++ b/TODO
@@ -1,3 +1,4 @@
+- Reimplement the interactive mode as a proper ui
- Move the LAYERDIR expansion hack into DataSmart, as that's where code that
depends upon its internals belongs
- Continue dropping fatal/SystemExit/sys.exit usage in favor of raising
diff --git a/bin/bitbake b/bin/bitbake
index 6d4aacb92..11ca7a4e4 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -105,9 +105,6 @@ Default BBFILES are the .bb files in the current directory.""")
parser.add_option("-f", "--force", help = "force run of specified cmd, regardless of stamp status",
action = "store_true", dest = "force", default = False)
- parser.add_option("-i", "--interactive", help = "drop into the interactive mode also called the BitBake shell.",
- action = "store_true", dest = "interactive", default = False)
-
parser.add_option("-c", "--cmd", help = "Specify task to execute. Note that this only executes the specified task for the providee and the packages it depends on, i.e. 'compile' does not implicitly call stage for the dependencies (IOW: use only if you know what you are doing). Depending on the base.bbclass a listtasks tasks is defined and will show available tasks",
action = "store", dest = "cmd")
diff --git a/lib/bb/cooker.py b/lib/bb/cooker.py
index 785e64115..265da6d33 100644
--- a/lib/bb/cooker.py
+++ b/lib/bb/cooker.py
@@ -151,9 +151,6 @@ class BBCooker:
self.commandlineAction = ["showVersions"]
elif self.configuration.parse_only:
self.commandlineAction = ["parseFiles"]
- # FIXME - implement
- #elif self.configuration.interactive:
- # self.interactiveMode()
elif self.configuration.dot_graph:
if self.configuration.pkgs_to_build:
self.commandlineAction = ["generateDotGraph", self.configuration.pkgs_to_build, self.configuration.cmd]