summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbin/bitbake4
1 files changed, 2 insertions, 2 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 37bed3695..886e7a86e 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -152,13 +152,13 @@ Default BBFILES are the .bb files in the current directory.""" )
# server is daemonized this logfile will be truncated.
cooker_logfile = os.path.join (os.getcwd(), "cooker.log")
- cooker = bb.cooker.BBCooker(configuration, server)
-
# Clear away any spurious environment variables. But don't wipe the
# environment totally. This is necessary to ensure the correct operation
# of the UIs (e.g. for DISPLAY, etc.)
bb.utils.clean_environment()
+ cooker = bb.cooker.BBCooker(configuration, server)
+
cooker.parseCommandLine()
serverinfo = server.BitbakeServerInfo(cooker.server)