summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2007-01-23 16:53:50 +0000
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2007-01-23 16:53:50 +0000
commit5254313950178bdefc582fc74eb2d0cc124adae4 (patch)
tree3c37d9f41e53a33e3aeeec3d5a3cbc146c093edf /setup.py
parent317eecaa69ca4c742f1636d5f7136172bde39cb5 (diff)
downloadbitbake-5254313950178bdefc582fc74eb2d0cc124adae4.tar.gz
Add proper GPLv2 headers to all BitBake files (from trunk)
- BitBake trunk is now GPLv2 only, no mix of MIT, FreeBSD License is left. - Update GPL headers to point to the correct address of the FSF - Update the list of authors. Uli Luckas, Seb Frankengul and Tim Amsell contributed to the sourcecode as well
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py27
1 files changed, 14 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index c00c11f4b..0433af32b 100755
--- a/setup.py
+++ b/setup.py
@@ -4,18 +4,19 @@
#
# Copyright (C) 2003 Chris Larson
#
-# This program is free software; you can redistribute it and/or modify it under
-# the terms of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or (at your option) any later
-# version.
-#
-# This program is distributed in the hope that it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
-# FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-# Place, Suite 330, Boston, MA 02111-1307 USA.
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2 as
+# published by the Free Software Foundation.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
from distutils.core import setup
import os, sys
@@ -49,7 +50,7 @@ import bb
import glob
setup(name='bitbake',
version=bb.__version__,
- license='GPL',
+ license='GPLv2',
url='http://developer.berlios.de/projects/bitbake/',
description='BitBake build tool',
long_description='BitBake is a simple tool for the execution of tasks. It is derived from Portage, which is the package management system used by the Gentoo Linux distribution. It is most commonly used to build packages, as it can easily use its rudamentary inheritence to abstract common operations, such as fetching sources, unpacking them, patching them, compiling them, and so on. It is the basis of the OpenEmbedded project, which is being used for OpenZaurus, Familiar, and a number of other Linux distributions.',