aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChristopher Larson <kergoth@gmail.com>2012-02-03 08:12:55 -0700
committerChristopher Larson <kergoth@gmail.com>2012-02-03 08:12:56 -0700
commitdb689a99beffea1a285cdfc74a58fe73f1666987 (patch)
treebdcfefc9060b5125527fdfeeb9623efb7762d6b0 /setup.py
parent74994e1f45c776a02e7e228e1204ab54d677da0a (diff)
downloadbitbake-db689a99beffea1a285cdfc74a58fe73f1666987.tar.gz
Revert the switch to futures for now
Without it, we get random hangs on parse failure. With it, some folks have seen hangs even on successful cases. The former is clearly less problematic. This is temporary, until I can finish investigating the root causes of both issues. Signed-off-by: Christopher Larson <kergoth@gmail.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 2 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index e86ddd15f..7921811c1 100755
--- a/setup.py
+++ b/setup.py
@@ -51,11 +51,10 @@ class Build(build):
setup(name='bitbake',
version = __version__,
- requires = ["ply", "progressbar", "futures"],
+ requires = ["ply", "progressbar"],
package_dir = {"": "lib"},
packages = ["bb.server", "bb.parse.parse_py", "bb.parse", "bb.fetch",
- "bb.fetch2", "bb.ui.crumbs", "bb.ui", "bb.pysh", "bb",
- "prserv", "concurrent", "concurrent.futures"],
+ "bb.fetch2", "bb.ui.crumbs", "bb.ui", "bb.pysh", "bb", "prserv"],
py_modules = ["codegen"],
scripts = ["bin/bitbake", "bin/bitbake-layers", "bin/bitbake-diffsigs", "bin/bitbake-prserv"],
data_files = [("share/bitbake", glob("conf/*") + glob("classes/*")),