aboutsummaryrefslogtreecommitdiffstats
path: root/lib
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2005-06-07 13:33:36 +0000
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2005-06-07 13:33:36 +0000
commitecfaa95522bd3914b8fa36210566bd2406688806 (patch)
tree3b41d3b2fc8fc659e06e65238c0fa44e9bc266fd /lib
parentdb872e763490b9cbc2f22bcee37b0d657ae7624c (diff)
downloadbitbake-ecfaa95522bd3914b8fa36210566bd2406688806.tar.gz
build in a try/except block and intercept faulty builds
Diffstat (limited to 'lib')
-rw-r--r--lib/bb/shell.py9
1 files changed, 6 insertions, 3 deletions
diff --git a/lib/bb/shell.py b/lib/bb/shell.py
index 7fde38960..bd8a1431e 100644
--- a/lib/bb/shell.py
+++ b/lib/bb/shell.py
@@ -47,9 +47,9 @@ except NameError:
from sets import Set as set
import sys, os, imp, readline
imp.load_source( "bitbake", os.path.dirname( sys.argv[0] )+"/bitbake" )
-from bb import make, data, parse, fatal
+from bb import data, parse, build, make, fatal
-__version__ = "0.3.5"
+__version__ = "0.3.6"
__credits__ = """BitBake Shell Version %s (C) 2005 Michael 'Mickey' Lauer <mickey@Vanille.de>
Type 'help' for more information, press CTRL-D to exit.""" % __version__
@@ -76,7 +76,10 @@ def buildCommand( params, cmd = "build" ):
if not parsed:
print "SHELL: D'oh! The .bb files haven't been parsed yet. Next time call 'parse' before building stuff. This time I'll do it for 'ya."
parseCommand( None )
- cooker.buildProvider( name )
+ try:
+ cooker.buildProvider( name )
+ except build.EventException:
+ print "ERROR: Couldn't build '%s'" % name
make.options.cmd = oldcmd