summaryrefslogtreecommitdiffstats
path: root/lib/toaster/toastergui/tables.py
diff options
context:
space:
mode:
authorBelen Barros Pena <belen.barros.pena@linux.intel.com>2016-04-28 13:45:17 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-13 22:04:29 +0100
commit5d4172bc005efe209de595f6a151ae9ed062d051 (patch)
tree5e1d50ee251b79a23cda1ed570e626c050482603 /lib/toaster/toastergui/tables.py
parent81798ab046b0717614e28e0a339172f3803e451b (diff)
downloadbitbake-5d4172bc005efe209de595f6a151ae9ed062d051.tar.gz
toaster: tweaks to recipe file downloads
* In the custom images table, show the recipe file and download icon only when the recipe file exists and can be downloaded. * Also in the custom images table, make sure the download icon tooltip shows on hover. * In the custom image details page, show the correct icon (download) next to the recipe file in the right hand column. * In the custom image details page, show the recipe file and download icon in the right hand column only when the recipe file exists and can be downloaded * Also in the custom image details page, simplify the help text we show when the 'download' button is disabled: it gave so much information about what's actually happening under the hood that it was a bit hard to follow. Signed-off-by: Belen Barros Pena <belen.barros.pena@linux.intel.com> Signed-off-by: Elliot Smith <elliot.smith@intel.com>
Diffstat (limited to 'lib/toaster/toastergui/tables.py')
-rw-r--r--lib/toaster/toastergui/tables.py7
1 files changed, 2 insertions, 5 deletions
diff --git a/lib/toaster/toastergui/tables.py b/lib/toaster/toastergui/tables.py
index caa2fba51..2bbef637a 100644
--- a/lib/toaster/toastergui/tables.py
+++ b/lib/toaster/toastergui/tables.py
@@ -495,12 +495,9 @@ class CustomImagesTable(ToasterTable):
static_data_template=name_link_template)
recipe_file_template = '''
- <code>{{data.name}}_{{data.version}}.bb</code>
{% if data.get_base_recipe_file %}
- <a href="{% url 'customrecipedownload' extra.pid data.pk %}">
- <i class="icon-download-alt" data-original-title="Download recipe
- file"></i>
- </a>
+ <code>{{data.name}}_{{data.version}}.bb</code>
+ <a href="{% url 'customrecipedownload' extra.pid data.pk %}" class="icon-download-alt get-help" title="Download recipe file"></a>
{% endif %}'''
self.add_column(title="Recipe file",