summaryrefslogtreecommitdiffstats
path: root/lib/bb
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2017-03-17 10:20:23 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-21 21:02:20 +0000
commiteeeed7693710e4a78fec639b8050d8efe4ea3c33 (patch)
tree95fd92b426145dd7cfee796eb0547fea5712db1e /lib/bb
parent7e6a3cd1472e1a1c8304b46611e1676914a68b59 (diff)
downloadbitbake-eeeed7693710e4a78fec639b8050d8efe4ea3c33.tar.gz
taskdata.py: include more information in error message about broken task depends
This is what was reported when variable expansion in the 'depends' varflag of a task was broken: ERROR: Error for .../refkit-image-common.bb, dependency ${@ does not contain exactly one ':' character. Task 'depends' should be specified in the form 'packagename:task' It's not clear which task had this broken 'depends' and while one can guess that variable expansion failed, the full expression isn't printed either. This is more useful: ERROR: Error for .../refkit-image-common.bb:do_stage_swupd_inputs[depends], dependency ${@ in ' virtual/fakeroot-native:do_populate_sysroot ${@ ' '.join(['bundle-refkit-image-common-%s:do_swupd_list_bundle' % x for x in '${SWUPD_BUNDLES}'.split()]) } ' does not contain exactly one ':' character. Task 'depends' should be specified in the form 'packagename:task' The 'depends' part gets repeated intentionally, to ensure that it doesn't get overlooked. Signed-off-by: Patrick Ohly <patrick.ohly@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'lib/bb')
-rw-r--r--lib/bb/taskdata.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/bb/taskdata.py b/lib/bb/taskdata.py
index 1f3b24c84..8c96a5628 100644
--- a/lib/bb/taskdata.py
+++ b/lib/bb/taskdata.py
@@ -97,7 +97,7 @@ class TaskData:
if dep:
parts = dep.split(":")
if len(parts) != 2:
- bb.msg.fatal("TaskData", "Error for %s, dependency %s does not contain exactly one ':' character.\n Task '%s' should be specified in the form 'packagename:task'" % (fn, dep, dep_name))
+ bb.msg.fatal("TaskData", "Error for %s:%s[%s], dependency %s in '%s' does not contain exactly one ':' character.\n Task '%s' should be specified in the form 'packagename:task'" % (fn, task, dep_name, dep, task_deps[dep_name][task], dep_name))
ids.append((parts[0], parts[1]))
seen(parts[0])
depends.extend(ids)