aboutsummaryrefslogtreecommitdiffstats
path: root/lib/bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2008-09-30 20:28:11 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2008-09-30 20:28:11 +0000
commitc6741cbaa6a7ebb5ae30c39f65701d76573a960d (patch)
tree6bcb8a82288d138c6a89277c4418a39f07899078 /lib/bb
parentdb2d02b7ee22557bfe56509f52e931a91a22d5d0 (diff)
downloadbitbake-c6741cbaa6a7ebb5ae30c39f65701d76573a960d.tar.gz
cooker.py: Rename __depends to __base_depends after configuration parsing so we don't recheck the validity of the config files time after time. Also bump the cache revision to match the format change (from poky)
Diffstat (limited to 'lib/bb')
-rw-r--r--lib/bb/cache.py2
-rw-r--r--lib/bb/cooker.py1
2 files changed, 2 insertions, 1 deletions
diff --git a/lib/bb/cache.py b/lib/bb/cache.py
index bcf393a57..fe38ea0ae 100644
--- a/lib/bb/cache.py
+++ b/lib/bb/cache.py
@@ -39,7 +39,7 @@ except ImportError:
import pickle
bb.msg.note(1, bb.msg.domain.Cache, "Importing cPickle failed. Falling back to a very slow implementation.")
-__cache_version__ = "128"
+__cache_version__ = "129"
class Cache:
"""
diff --git a/lib/bb/cooker.py b/lib/bb/cooker.py
index c92ad70a2..8eb1a410f 100644
--- a/lib/bb/cooker.py
+++ b/lib/bb/cooker.py
@@ -758,6 +758,7 @@ class BBCooker:
self.handleCollections( bb.data.getVar("BBFILE_COLLECTIONS", self.configuration.data, 1) )
bb.msg.debug(1, bb.msg.domain.Collection, "collecting .bb files")
+ bb.data.renameVar("__depends", "__base_depends", self.configuration.data)
(filelist, masked) = self.collect_bbfiles()
self.parse_bbfiles(filelist, masked)
bb.msg.debug(1, bb.msg.domain.Collection, "parsing complete")