summaryrefslogtreecommitdiffstats
path: root/lib/bb/ui/knotty.py
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-10 10:55:48 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-06 15:31:21 +0100
commitd4574ad90638e58291bf6edfa19b74161b062b6e (patch)
treecf8f2c6cf63483647d8b4087fe50cffd545d55eb /lib/bb/ui/knotty.py
parent2b0194b408d6d1835f04b20cf5cbd6b0d255869b (diff)
downloadbitbake-d4574ad90638e58291bf6edfa19b74161b062b6e.tar.gz
bitbake/cache.py: Ensure skipped recipes make it into the cache to avoid reparsing
(From Poky rev: 001a555c2f755d4f8a69b113656d9307ca7ee597) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'lib/bb/ui/knotty.py')
-rw-r--r--lib/bb/ui/knotty.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/lib/bb/ui/knotty.py b/lib/bb/ui/knotty.py
index 9f2b78702..1396939fc 100644
--- a/lib/bb/ui/knotty.py
+++ b/lib/bb/ui/knotty.py
@@ -149,12 +149,17 @@ def main(server, eventHandler):
logger.info(event._message)
continue
if isinstance(event, bb.event.ParseStarted):
+ if event.total == 0:
+ continue
parseprogress = new_progress("Parsing recipes", event.total).start()
continue
if isinstance(event, bb.event.ParseProgress):
parseprogress.update(event.current)
continue
if isinstance(event, bb.event.ParseCompleted):
+ if not parseprogress:
+ continue
+
parseprogress.finish()
print(("Parsing of %d .bb files complete (%d cached, %d parsed). %d targets, %d skipped, %d masked, %d errors."
% ( event.total, event.cached, event.parsed, event.virtuals, event.skipped, event.masked, event.errors)))