summaryrefslogtreecommitdiffstats
path: root/lib/bb/ui/knotty.py
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-01-20 12:16:40 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-01-20 12:16:40 +0000
commit095211d8e245ae81d3246340b5bd2b322d39a6f5 (patch)
tree06e54f70a548047abeba6117cfd942cc742e32ca /lib/bb/ui/knotty.py
parent5b2b17413e9b4939a3bfabe65f415b043342ad9e (diff)
downloadbitbake-095211d8e245ae81d3246340b5bd2b322d39a6f5.tar.gz
Improve BBCLASSEXTEND handling for skipped packages and report better parsing statistics
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'lib/bb/ui/knotty.py')
-rw-r--r--lib/bb/ui/knotty.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/bb/ui/knotty.py b/lib/bb/ui/knotty.py
index 6baed836a..c69fd6ca6 100644
--- a/lib/bb/ui/knotty.py
+++ b/lib/bb/ui/knotty.py
@@ -114,8 +114,8 @@ def init(server, eventHandler):
sys.stdout.write("done.")
sys.stdout.flush()
if x == y:
- print("\nParsing finished. %d cached, %d parsed, %d skipped, %d masked, %d errors."
- % ( event.cached, event.parsed, event.skipped, event.masked, event.errors))
+ print("\nParsing of %d .bb files complete (%d cached, %d parsed). %d targets, %d skipped, %d masked, %d errors."
+ % ( event.total, event.cached, event.parsed, event.virtuals, event.skipped, event.masked, event.errors))
continue
if isinstance(event, bb.command.CookerCommandCompleted):