summaryrefslogtreecommitdiffstats
path: root/lib/bb/tests/runqueue-tests/recipes/fails-mc/fails-mc2.bb
diff options
context:
space:
mode:
authorJoshua Watt <jpewhacker@gmail.com>2021-02-19 20:37:00 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-20 11:16:53 +0000
commitc3168df330a4563cbd03ba74de55a22217d823ed (patch)
tree254d750298faddd2976b7b39f246dc9fda2b7e5a /lib/bb/tests/runqueue-tests/recipes/fails-mc/fails-mc2.bb
parent915330e1dbae1ee8fd9a0358decf2c294f771961 (diff)
downloadbitbake-c3168df330a4563cbd03ba74de55a22217d823ed.tar.gz
event: Fix broken builds when multiconfig has a hyphen in the name
5f7fdf7b2d ("bitbake: event: Prevent bitbake from executing event handler for wrong multiconfig target") broke multiconfig builds contain a hyphen, since it's attempt to use the multiconfig as part of a function name and python functions are not allowed to contain a hyphen. Rework the bitbake multiconfig test to test a multiconfig with a hyphen and one with an underscore to validate this doesn't break in the future. Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'lib/bb/tests/runqueue-tests/recipes/fails-mc/fails-mc2.bb')
-rw-r--r--lib/bb/tests/runqueue-tests/recipes/fails-mc/fails-mc2.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/bb/tests/runqueue-tests/recipes/fails-mc/fails-mc2.bb b/lib/bb/tests/runqueue-tests/recipes/fails-mc/fails-mc2.bb
index cc69e7b82..3c172ef97 100644
--- a/lib/bb/tests/runqueue-tests/recipes/fails-mc/fails-mc2.bb
+++ b/lib/bb/tests/runqueue-tests/recipes/fails-mc/fails-mc2.bb
@@ -1,4 +1,4 @@
python () {
- if d.getVar("BB_CURRENT_MC") == "mc2":
- bb.fatal("Multiconfig is mc2")
+ if d.getVar("BB_CURRENT_MC") == "mc_2":
+ bb.fatal("Multiconfig is mc_2")
}