summaryrefslogtreecommitdiffstats
path: root/lib/bb/tests/runqueue-tests/recipes/fails-mc/fails-mc1.bb
diff options
context:
space:
mode:
authorJoshua Watt <JPEWhacker@gmail.com>2020-06-05 22:15:35 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-08 21:33:27 +0100
commit513fc2dddf13d5e344162c26d89d2dde2fe85634 (patch)
tree461f619beea39298570792063106da6b1e91fbca /lib/bb/tests/runqueue-tests/recipes/fails-mc/fails-mc1.bb
parent3c5c7346adf4ca7ec761c08738f12401ba75b7c8 (diff)
downloadbitbake-513fc2dddf13d5e344162c26d89d2dde2fe85634.tar.gz
bitbake: tests: Add tests for BBMASK in multiconfig
Adds a test to validate that multiconfigs can independently mask off recipes by setting BBMASK. See the test description for further information about how the test works. Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'lib/bb/tests/runqueue-tests/recipes/fails-mc/fails-mc1.bb')
-rw-r--r--lib/bb/tests/runqueue-tests/recipes/fails-mc/fails-mc1.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/lib/bb/tests/runqueue-tests/recipes/fails-mc/fails-mc1.bb b/lib/bb/tests/runqueue-tests/recipes/fails-mc/fails-mc1.bb
new file mode 100644
index 000000000..17a181fff
--- /dev/null
+++ b/lib/bb/tests/runqueue-tests/recipes/fails-mc/fails-mc1.bb
@@ -0,0 +1,5 @@
+python () {
+ if d.getVar("BB_CURRENT_MC") == "mc1":
+ bb.fatal("Multiconfig is mc1")
+}
+