aboutsummaryrefslogtreecommitdiffstats
path: root/lib/bb/siggen.py
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-07 17:47:37 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-08 11:01:36 +0000
commitd753644c67d163f338f2bdc3d600203e8b1a5734 (patch)
tree2335fc5c9280f66aa38c1bdfcb8755c4cde27832 /lib/bb/siggen.py
parent54ecf96c6f031927ee2410f6efde4e16f19bbf66 (diff)
downloadbitbake-d753644c67d163f338f2bdc3d600203e8b1a5734.tar.gz
siggen: Fix shared work checksum mismatch/rebuild issues
Similar to the last shared work task signature bug, we've found another one. Looking at the improved output of diffsigs in this case: runtaskdeps changed from [ 'autoconf_2.69.bb.do_populate_sysroot:virtual:native', 'gnu-config_20120814.bb.do_populate_sysroot:virtual:native', 'libgcc-initial_4.9.bb.do_patch:virtual:nativesdk' ] to [ 'autoconf_2.69.bb.do_populate_sysroot:virtual:native', 'gcc-crosssdk-initial_4.9.bb.do_patch', 'gnu-config_20120814.bb.do_populate_sysroot:virtual:native' ] so we can get a different task hash since libgcc sorts before gnu-config and gcc sorts after it. We could do with a way of fixing this, the best I can come up with is to include a single parent directory. Since recipes are never at the top of any metadata trees I've seen, this should suffice for now. I'm planning to burn the concept of shared work within bitbake and do something at the metadata level in the 1.8 timeframe as its just too fragile as things stand and hard to fix well. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'lib/bb/siggen.py')
-rw-r--r--lib/bb/siggen.py5
1 files changed, 2 insertions, 3 deletions
diff --git a/lib/bb/siggen.py b/lib/bb/siggen.py
index e92a9c48a..510307353 100644
--- a/lib/bb/siggen.py
+++ b/lib/bb/siggen.py
@@ -295,10 +295,9 @@ def dump_this_task(outfile, d):
bb.parse.siggen.dump_sigtask(fn, task, outfile, "customfile")
def clean_basepath(a):
+ b = a.rsplit("/", 2)[1] + a.rsplit("/", 2)[2]
if a.startswith("virtual:"):
- b = a.rsplit("/", 1)[1] + ":" + a.rsplit(":", 1)[0]
- else:
- b = a.rsplit("/", 1)[1]
+ b = b + ":" + a.rsplit(":", 1)[0]
return b
def clean_basepaths(a):