summaryrefslogtreecommitdiffstats
path: root/lib/bb/shell.py
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2006-09-09 23:29:36 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2006-09-09 23:29:36 +0000
commitdb9333b8c21fc361a4a49c6409d68b04bbaa8f86 (patch)
tree7e9d1c8eef70e4faca4859fc50a0717ffb2f5662 /lib/bb/shell.py
parent2a0e2b7924f32e0fff7a7371be805700b646525f (diff)
downloadbitbake-db9333b8c21fc361a4a49c6409d68b04bbaa8f86.tar.gz
Turn BBParsingStatus into CacheData and move to cache.py
Diffstat (limited to 'lib/bb/shell.py')
-rw-r--r--lib/bb/shell.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/bb/shell.py b/lib/bb/shell.py
index 889d90fb1..dbf7363d4 100644
--- a/lib/bb/shell.py
+++ b/lib/bb/shell.py
@@ -57,7 +57,7 @@ try:
except NameError:
from sets import Set as set
import sys, os, readline, socket, httplib, urllib, commands, popen2, copy, shlex, Queue, fnmatch
-from bb import data, parse, build, fatal
+from bb import data, parse, build, fatal, cache
__version__ = "0.5.3.1"
__credits__ = """BitBake Shell Version %s (C) 2005 Michael 'Mickey' Lauer <mickey@Vanille.de>
@@ -392,7 +392,7 @@ SRC_URI = ""
def parse( self, params ):
"""(Re-)parse .bb files and calculate the dependency graph"""
- cooker.status = cooker.ParsingStatus()
+ cooker.status = cache.CacheData()
ignore = data.getVar("ASSUME_PROVIDED", cooker.configuration.data, 1) or ""
cooker.status.ignored_dependencies = set( ignore.split() )
cooker.handleCollections( data.getVar("BBFILE_COLLECTIONS", cooker.configuration.data, 1) )