summaryrefslogtreecommitdiffstats
path: root/lib/bb/shell.py
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2006-09-11 11:34:00 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2006-09-11 11:34:00 +0000
commit2a86e0295a606ce90776ffe5dd3c5303e18e65a3 (patch)
tree8325c897e48ae8be64288c97949b32d326e3d381 /lib/bb/shell.py
parent3877abf437ff67a010b3e14c28da7f2c42bbd332 (diff)
downloadbitbake-2a86e0295a606ce90776ffe5dd3c5303e18e65a3.tar.gz
bitbake/lib/bb/shell.py:
bitbake/bin/bitbake: Split collect_bbfiles into collect_bbfiles and parse_bbfiles Allow -b option to accept an expression which uniquely identifies a .bb file instead of requiring a full path Disable BBFILES support within .bb files (it was already non-functional)
Diffstat (limited to 'lib/bb/shell.py')
-rw-r--r--lib/bb/shell.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/bb/shell.py b/lib/bb/shell.py
index 7b6d5415e..ac49d5c2c 100644
--- a/lib/bb/shell.py
+++ b/lib/bb/shell.py
@@ -422,7 +422,8 @@ SRC_URI = ""
cooker.status.ignored_dependencies = set( ignore.split() )
cooker.handleCollections( data.getVar("BBFILE_COLLECTIONS", cooker.configuration.data, 1) )
- cooker.collect_bbfiles( cooker.myProgressCallback )
+ (filelist, masked) = cooker.collect_bbfiles()
+ cooker.parse_bbfiles(filelist, masked, cooker.myProgressCallback)
cooker.buildDepgraph()
global parsed
parsed = True