aboutsummaryrefslogtreecommitdiffstats
path: root/lib/bb/runqueue.py
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2010-02-08 18:50:34 +0100
committerChris Larson <clarson@kergoth.com>2010-02-10 14:12:03 -0700
commit00eaf76fdc32eb515995b47dfa69eb90ca904b37 (patch)
treea81ad8f1e33429971a5eba375318335a7a2ea1f8 /lib/bb/runqueue.py
parent457fb59f10ed59269b8bda3ee53bbeded5d33eb5 (diff)
downloadbitbake-00eaf76fdc32eb515995b47dfa69eb90ca904b37.tar.gz
runqueue.py: improve printing dependent tasks
Print names instead of Task-IDs (and not mentioning they're task ids). Previously we printed e.g.: Dependency loop #1 found: Task 89 (/there/src/oe/openembedded/recipes/busybox/busybox-native_1.15.2.bb, do_configure) (depends: Set([88, 282, 92, 87])) Now we say Dependency loop #1 found: Task 89 (/there/src/oe/openembedded/recipes/busybox/busybox-native_1.15.2.bb, do_configure) (dependent Task-IDs ['busybox-native, do_patch', 'update-rc.d, do_populate_staging', 'busybox-native, do_populate_staging', 'shasum-native.bb, do_populate_staging', 'busybox-native, do_unpack']) Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Diffstat (limited to 'lib/bb/runqueue.py')
-rw-r--r--lib/bb/runqueue.py12
1 files changed, 10 insertions, 2 deletions
diff --git a/lib/bb/runqueue.py b/lib/bb/runqueue.py
index 3a438894b..f315b5d40 100644
--- a/lib/bb/runqueue.py
+++ b/lib/bb/runqueue.py
@@ -175,9 +175,17 @@ class RunQueue:
self.runq_task = []
self.runq_depends = []
self.runq_revdeps = []
-
self.state = runQueuePrepare
+ def runq_depends_names(self, ids):
+ import re
+ ret = []
+ for id in self.runq_depends[ids]:
+ nam = os.path.basename(self.get_user_idstring(id))
+ nam = re.sub("_[^,]*,", ",", nam)
+ ret.extend([nam])
+ return ret
+
def get_user_idstring(self, task):
fn = self.taskData.fn_index[self.runq_fnid[task]]
taskname = self.runq_task[task]
@@ -248,7 +256,7 @@ class RunQueue:
valid_chains.append(new_chain)
msgs.append("Dependency loop #%d found:\n" % len(valid_chains))
for dep in new_chain:
- msgs.append(" Task %s (%s) (depends: %s)\n" % (dep, self.get_user_idstring(dep), self.runq_depends[dep]))
+ msgs.append(" Task %s (%s) (dependent Tasks %s)\n" % (dep, self.get_user_idstring(dep), self.runq_depends_names(dep)))
msgs.append("\n")
if len(valid_chains) > 10:
msgs.append("Aborted dependency loops search after 10 matches.\n")