summaryrefslogtreecommitdiffstats
path: root/lib/bb/runqueue.py
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-02-13 11:41:31 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-22 20:24:34 +0000
commit293c796e8a3d1f74ca1e51017b6dede261612281 (patch)
treedeef9d9683a853b8319b90f9bf453e39a84be9a7 /lib/bb/runqueue.py
parent8e0744d6d4ab306809618adf63463a04d6664e48 (diff)
downloadbitbake-293c796e8a3d1f74ca1e51017b6dede261612281.tar.gz
bitbake: show appropriate warnings for universe target
When building the universe target: * Show a warning about universe likely producing errors * Multiprovider errors are now shown as warnings Also remove an unused "error" variable in runqueue.py. Fixes [YOCTO #1936] Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'lib/bb/runqueue.py')
-rw-r--r--lib/bb/runqueue.py10
1 files changed, 7 insertions, 3 deletions
diff --git a/lib/bb/runqueue.py b/lib/bb/runqueue.py
index 00e9981f3..d1d9ad93b 100644
--- a/lib/bb/runqueue.py
+++ b/lib/bb/runqueue.py
@@ -187,6 +187,7 @@ class RunQueueData:
self.taskData = taskData
self.targets = targets
self.rq = rq
+ self.warn_multi_bb = False
self.stampwhitelist = cfgData.getVar("BB_STAMP_WHITELIST", 1) or ""
self.multi_provider_whitelist = (cfgData.getVar("MULTI_PROVIDER_WHITELIST", 1) or "").split()
@@ -674,11 +675,14 @@ class RunQueueData:
prov_list[prov] = [fn]
elif fn not in prov_list[prov]:
prov_list[prov].append(fn)
- error = False
for prov in prov_list:
if len(prov_list[prov]) > 1 and prov not in self.multi_provider_whitelist:
- error = True
- logger.error("Multiple .bb files are due to be built which each provide %s (%s).\n This usually means one provides something the other doesn't and should.", prov, " ".join(prov_list[prov]))
+ msg = "Multiple .bb files are due to be built which each provide %s (%s)." % (prov, " ".join(prov_list[prov]))
+ if self.warn_multi_bb:
+ logger.warn(msg)
+ else:
+ msg += "\n This usually means one provides something the other doesn't and should."
+ logger.error(msg)
# Create a whitelist usable by the stamp checks