summaryrefslogtreecommitdiffstats
path: root/lib/bb/runqueue.py
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-13 15:39:07 +0100
committerChris Larson <chris_larson@mentor.com>2010-12-03 12:24:46 -0700
commit61c78368b732739be5ece4777fa570adf5a6c83b (patch)
tree16c3e5567cae4166735d0ef4a69a808f72d6e84d /lib/bb/runqueue.py
parent6386e99b770be17af53495ec3a7d6c830272b743 (diff)
downloadbitbake-61c78368b732739be5ece4777fa570adf5a6c83b.tar.gz
bitbake/build.py: Set BB_FILENAME to represent the .bb file being built (including any virtual prefix)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'lib/bb/runqueue.py')
-rw-r--r--lib/bb/runqueue.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/bb/runqueue.py b/lib/bb/runqueue.py
index cd3c25e4f..01e067d5b 100644
--- a/lib/bb/runqueue.py
+++ b/lib/bb/runqueue.py
@@ -1113,7 +1113,7 @@ class RunQueue:
bb.data.setVar("__RUNQUEUE_DO_NOT_USE_EXTERNALLY2", fn, self.cooker.configuration.data)
try:
the_data = bb.cache.Cache.loadDataFull(fn, self.cooker.get_file_appends(fn), self.cooker.configuration.data)
- bb.build.exec_task(taskname, the_data)
+ bb.build.exec_task(fn, taskname, the_data)
except Exception as exc:
logger.critical(str(exc))
os._exit(1)