aboutsummaryrefslogtreecommitdiffstats
path: root/lib/bb/parse
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-12-09 12:32:18 +0000
committerChris Larson <clarson@kergoth.com>2004-12-09 12:32:18 +0000
commit7726a4cab1fb7de0edb155f2397b81c3aea18e73 (patch)
tree83f7dcb8422ddcd7eb707af859a4339b94e63051 /lib/bb/parse
parent034c2463b47ad09b92788e24b6ec5158ed14fdf3 (diff)
downloadbitbake-7726a4cab1fb7de0edb155f2397b81c3aea18e73.tar.gz
Add the location of the .bb file to BBPATH in the parser's handle() function rather than load_oefile, since we need it done for 'include'd files as well as those directly loaded by the 'bitbake' commandline tool.
Diffstat (limited to 'lib/bb/parse')
-rw-r--r--lib/bb/parse/BBHandler.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/lib/bb/parse/BBHandler.py b/lib/bb/parse/BBHandler.py
index 32f4ce873..619b45d94 100644
--- a/lib/bb/parse/BBHandler.py
+++ b/lib/bb/parse/BBHandler.py
@@ -119,6 +119,9 @@ def handle(fn, d = {}, include = 0):
i[0:0] = ["base"]
inherit(i, d)
+ bbpath.insert(0, os.path.dirname(fn))
+ data.setVar('BBPATH', ":".join(bbpath), d)
+
lineno = 0
while 1:
lineno = lineno + 1