aboutsummaryrefslogtreecommitdiffstats
path: root/lib/bb/parse/parse_py/BBHandler.py
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-24 11:03:33 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-24 14:35:14 +0100
commitd7ec0f90354e60c415a01429bf26746c1d63b7ad (patch)
treef01d5f3cada9f02575592a894d60a42de090a1c2 /lib/bb/parse/parse_py/BBHandler.py
parent2c4a21dc8a588c8cf05549ddd9734731a46bea10 (diff)
downloadbitbake-d7ec0f90354e60c415a01429bf26746c1d63b7ad.tar.gz
BBHandler: Tweak some data store access methods to the preferred syntax
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'lib/bb/parse/parse_py/BBHandler.py')
-rw-r--r--lib/bb/parse/parse_py/BBHandler.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/lib/bb/parse/parse_py/BBHandler.py b/lib/bb/parse/parse_py/BBHandler.py
index 815bce1d7..625a2a21f 100644
--- a/lib/bb/parse/parse_py/BBHandler.py
+++ b/lib/bb/parse/parse_py/BBHandler.py
@@ -69,7 +69,7 @@ def supports(fn, d):
return os.path.splitext(fn)[-1] in [".bb", ".bbclass", ".inc"]
def inherit(files, fn, lineno, d):
- __inherit_cache = data.getVar('__inherit_cache', d) or []
+ __inherit_cache = d.getVar('__inherit_cache') or []
files = d.expand(files).split()
for file in files:
if not os.path.isabs(file) and not file.endswith(".bbclass"):
@@ -80,7 +80,7 @@ def inherit(files, fn, lineno, d):
__inherit_cache.append( file )
data.setVar('__inherit_cache', __inherit_cache, d)
include(fn, file, lineno, d, "inherit")
- __inherit_cache = data.getVar('__inherit_cache', d) or []
+ __inherit_cache = d.getVar('__inherit_cache') or []
def get_statements(filename, absolute_filename, base_name):
global cached_statements
@@ -126,13 +126,13 @@ def handle(fn, d, include):
if ext == ".bbclass":
__classname__ = root
classes.append(__classname__)
- __inherit_cache = data.getVar('__inherit_cache', d) or []
+ __inherit_cache = d.getVar('__inherit_cache') or []
if not fn in __inherit_cache:
__inherit_cache.append(fn)
data.setVar('__inherit_cache', __inherit_cache, d)
if include != 0:
- oldfile = data.getVar('FILE', d)
+ oldfile = d.getVar('FILE')
else:
oldfile = None