aboutsummaryrefslogtreecommitdiffstats
path: root/lib/bb/parse/ast.py
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2016-11-25 15:28:08 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:47:45 +0000
commit3b45c479de8640f92dd1d9f147b02e1eecfaadc8 (patch)
treeba0d71bdd8028442fd06002dc09e66ddf8291f6d /lib/bb/parse/ast.py
parent3cb0d1c78b4c2e4f251a59b86c8da583828ad08b (diff)
downloadbitbake-3b45c479de8640f92dd1d9f147b02e1eecfaadc8.tar.gz
bitbake: remove True option to getVar calls
getVar() now defaults to expanding by default, thus remove the True option from getVar() calls with a regex search and replace. Search made with the following regex: getVar ?\(( ?[^,()]*), True\) Signed-off-by: Joshua Lock <joshua.g.lock@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'lib/bb/parse/ast.py')
-rw-r--r--lib/bb/parse/ast.py12
1 files changed, 6 insertions, 6 deletions
diff --git a/lib/bb/parse/ast.py b/lib/bb/parse/ast.py
index fa83b1898..a3990e5b3 100644
--- a/lib/bb/parse/ast.py
+++ b/lib/bb/parse/ast.py
@@ -407,7 +407,7 @@ def _expand_versions(versions):
versions = itertools.chain(newversions, versions)
def multi_finalize(fn, d):
- appends = (d.getVar("__BBAPPEND", True) or "").split()
+ appends = (d.getVar("__BBAPPEND") or "").split()
for append in appends:
logger.debug(1, "Appending .bbappend file %s to %s", append, fn)
bb.parse.BBHandler.handle(append, d, True)
@@ -422,16 +422,16 @@ def multi_finalize(fn, d):
d.setVar("__SKIPPED", e.args[0])
datastores = {"": safe_d}
- versions = (d.getVar("BBVERSIONS", True) or "").split()
+ versions = (d.getVar("BBVERSIONS") or "").split()
if versions:
- pv = orig_pv = d.getVar("PV", True)
+ pv = orig_pv = d.getVar("PV")
baseversions = {}
def verfunc(ver, d, pv_d = None):
if pv_d is None:
pv_d = d
- overrides = d.getVar("OVERRIDES", True).split(":")
+ overrides = d.getVar("OVERRIDES").split(":")
pv_d.setVar("PV", ver)
overrides.append(ver)
bpv = baseversions.get(ver) or orig_pv
@@ -466,7 +466,7 @@ def multi_finalize(fn, d):
_create_variants(datastores, versions, verfunc, onlyfinalise)
- extended = d.getVar("BBCLASSEXTEND", True) or ""
+ extended = d.getVar("BBCLASSEXTEND") or ""
if extended:
# the following is to support bbextends with arguments, for e.g. multilib
# an example is as follows:
@@ -484,7 +484,7 @@ def multi_finalize(fn, d):
else:
extendedmap[ext] = ext
- pn = d.getVar("PN", True)
+ pn = d.getVar("PN")
def extendfunc(name, d):
if name != extendedmap[name]:
d.setVar("BBEXTENDCURR", extendedmap[name])