aboutsummaryrefslogtreecommitdiffstats
path: root/lib/bb/data.py
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2018-11-23 19:13:44 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-01 11:38:49 +0000
commit0cdc5b81fc1f5e5281a525a657e420ebc3bb9e90 (patch)
tree7191423ac762b790171fad5cb8398504aace7198 /lib/bb/data.py
parent3f1f183a17bf3580da8a4ffd6dab30b62c2654a8 (diff)
downloadbitbake-0cdc5b81fc1f5e5281a525a657e420ebc3bb9e90.tar.gz
bitbake: BBHandler: Check tab indentation for python code
The previous check was in data.py which only can check code like "python funcname()" in the dependency chain, but there are 3 kinds of python functions: - python() - def py_funcname() - python funcname() Add the checking to BBHandler to check and warn for all of them. The warning looks like: WARNING: /path/to/recipes-core/busybox/busybox_1.29.2.bb: python should use 4 spaces indentation, but found tabs in busybox.inc, line 75 Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'lib/bb/data.py')
-rw-r--r--lib/bb/data.py2
1 files changed, 0 insertions, 2 deletions
diff --git a/lib/bb/data.py b/lib/bb/data.py
index d66d98cc8..6bcfcf46c 100644
--- a/lib/bb/data.py
+++ b/lib/bb/data.py
@@ -322,8 +322,6 @@ def build_dependencies(key, keys, shelldeps, varflagsexcl, d):
if varflags.get("python"):
value = d.getVarFlag(key, "_content", False)
parser = bb.codeparser.PythonParser(key, logger)
- if value and "\t" in value:
- logger.warning("Variable %s contains tabs, please remove these (%s)" % (key, d.getVar("FILE")))
parser.parse_python(value, filename=varflags.get("filename"), lineno=varflags.get("lineno"))
deps = deps | parser.references
deps = deps | (keys & parser.execs)