aboutsummaryrefslogtreecommitdiffstats
path: root/lib/bb/cooker.py
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2008-09-30 20:28:11 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2008-09-30 20:28:11 +0000
commitc6741cbaa6a7ebb5ae30c39f65701d76573a960d (patch)
tree6bcb8a82288d138c6a89277c4418a39f07899078 /lib/bb/cooker.py
parentdb2d02b7ee22557bfe56509f52e931a91a22d5d0 (diff)
downloadbitbake-c6741cbaa6a7ebb5ae30c39f65701d76573a960d.tar.gz
cooker.py: Rename __depends to __base_depends after configuration parsing so we don't recheck the validity of the config files time after time. Also bump the cache revision to match the format change (from poky)
Diffstat (limited to 'lib/bb/cooker.py')
-rw-r--r--lib/bb/cooker.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/bb/cooker.py b/lib/bb/cooker.py
index c92ad70a2..8eb1a410f 100644
--- a/lib/bb/cooker.py
+++ b/lib/bb/cooker.py
@@ -758,6 +758,7 @@ class BBCooker:
self.handleCollections( bb.data.getVar("BBFILE_COLLECTIONS", self.configuration.data, 1) )
bb.msg.debug(1, bb.msg.domain.Collection, "collecting .bb files")
+ bb.data.renameVar("__depends", "__base_depends", self.configuration.data)
(filelist, masked) = self.collect_bbfiles()
self.parse_bbfiles(filelist, masked)
bb.msg.debug(1, bb.msg.domain.Collection, "parsing complete")