summaryrefslogtreecommitdiffstats
path: root/lib/bb/cooker.py
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-24 13:56:34 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-24 14:36:12 +0100
commit72fc62ca124a24e2dbe404a3c83a49608a7c7931 (patch)
tree3ad15bcbf367c9458b8db8ca00d402e93c4a1926 /lib/bb/cooker.py
parent884a0b2d927404991b7e23d5bbfab096a5b7e849 (diff)
downloadbitbake-72fc62ca124a24e2dbe404a3c83a49608a7c7931.tar.gz
bitbake/cooker: Ensure matchFile returns full pathnames
We should always be passing full pathnames around within bitbake. If a file was referenced as a relative path to the current working directory, it might not get passed through the abspath call and hence the cwd would not get added as a prefix. This change adds a second pass at ensuring we only return absolute paths. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'lib/bb/cooker.py')
-rw-r--r--lib/bb/cooker.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/bb/cooker.py b/lib/bb/cooker.py
index 8ad492265..bafd832a6 100644
--- a/lib/bb/cooker.py
+++ b/lib/bb/cooker.py
@@ -985,12 +985,12 @@ class BBCooker:
"""
Find the .bb files which match the expression in 'buildfile'.
"""
-
if bf.startswith("/") or bf.startswith("../"):
bf = os.path.abspath(bf)
filelist, masked = self.collect_bbfiles()
try:
os.stat(bf)
+ bf = os.path.abspath(bf)
return [bf]
except OSError:
regexp = re.compile(bf)