summaryrefslogtreecommitdiffstats
path: root/lib/bb/cooker.py
diff options
context:
space:
mode:
authorCristiana Voicu <cristiana.voicu@intel.com>2013-07-29 10:02:24 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-06 12:59:21 +0100
commit5629007f2b984005e3a8ac5d9b71422cbc2f1409 (patch)
treea9b0bc4e9c429cd4a5ac5dd27b73dbdc9ba558c4 /lib/bb/cooker.py
parent96ffa00945c7eb09a0132fa47159aef3ef20fb3e (diff)
downloadbitbake-5629007f2b984005e3a8ac5d9b71422cbc2f1409.tar.gz
hob/bitbake: save the description of a custom image
When an new image is saved, the dialog for this action has a field for the description. Changed how an image is saved, by appending the DESCRIPTION variable at the end of the .bb file. [YOCTO #4193] Signed-off-by: Cristiana Voicu <cristiana.voicu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'lib/bb/cooker.py')
-rw-r--r--lib/bb/cooker.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/lib/bb/cooker.py b/lib/bb/cooker.py
index 4a5638fb6..7ca9947df 100644
--- a/lib/bb/cooker.py
+++ b/lib/bb/cooker.py
@@ -1100,7 +1100,7 @@ class BBCooker:
self.configuration.server_register_idlecallback(buildTargetsIdle, rq)
- def generateNewImage(self, image, base_image, package_queue, timestamp):
+ def generateNewImage(self, image, base_image, package_queue, timestamp, description):
'''
Create a new image with a "require"/"inherit" base_image statement
'''
@@ -1125,6 +1125,9 @@ class BBCooker:
package_install += "\"\n"
imagefile.write(package_install)
+ description_var = "DESCRIPTION = \"" + description + "\"\n"
+ imagefile.write(description_var)
+
self.state = state.initial
if timestamp:
return timestr