summaryrefslogtreecommitdiffstats
path: root/lib/bb/cache.py
diff options
context:
space:
mode:
authorEnrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>2010-03-21 23:02:56 +0100
committerChris Larson <chris_larson@mentor.com>2010-04-09 07:53:28 -0700
commitf1c7fe9fc12161ceb3fe201cde370b929b208729 (patch)
treee5fd8750b169d295611d6089bac0564e16797f12 /lib/bb/cache.py
parentc4e31d7fe1d15a1e3ef2a453e7c7812d403d22cb (diff)
downloadbitbake-f1c7fe9fc12161ceb3fe201cde370b929b208729.tar.gz
Made '-b' work with BBCLASSEXTEND
When BBCLASSEXTEND is set, '-b' builds usually failed with messages like | ERROR: Parsing error data_fn virtual:native:<recipe>.bb and fn <recipe>.bb don't match | | File ".../bb/providers.py", line 47, in sortPriorities | priority = dataCache.bbfile_priority[f] | KeyError: 'virtual:native:<recipe>.bb' This patch fixes it and allows to specify the alternative class in a way like | ./bitbake -b virtual:native:<recipe>.bb This patch was written to be so minimal as possible; variables should be probably renamed to reflect their new meaning. Signed-off-by: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Diffstat (limited to 'lib/bb/cache.py')
-rw-r--r--lib/bb/cache.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/bb/cache.py b/lib/bb/cache.py
index f3ba714d4..30857864d 100644
--- a/lib/bb/cache.py
+++ b/lib/bb/cache.py
@@ -137,6 +137,7 @@ class Cache:
# If we're a virtual class we need to make sure all our depends are appended
# to the depends of fn.
depends = self.getVar("__depends", virtualfn, True) or []
+ self.depends_cache.setdefault(fn, {})
if "__depends" not in self.depends_cache[fn] or not self.depends_cache[fn]["__depends"]:
self.depends_cache[fn]["__depends"] = depends
for dep in depends: