aboutsummaryrefslogtreecommitdiffstats
path: root/doc
diff options
context:
space:
mode:
authorNicolas Dechesne <nicolas.dechesne@linaro.org>2020-09-08 16:11:14 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-16 18:13:44 +0100
commit219b2348f51a02b102cd1c34c87f279c83ae4908 (patch)
treebf7d3ac18610a3b9f0fe09b8a0824a60adf1d110 /doc
parent35fdc18549607e195d424f554e8d4b74e87fd245 (diff)
downloadbitbake-219b2348f51a02b102cd1c34c87f279c83ae4908.tar.gz
sphinx: Makefile.sphinx: add clean and publish targets
Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org>
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile.sphinx13
1 files changed, 12 insertions, 1 deletions
diff --git a/doc/Makefile.sphinx b/doc/Makefile.sphinx
index 933c77ee5..c663c2954 100644
--- a/doc/Makefile.sphinx
+++ b/doc/Makefile.sphinx
@@ -7,12 +7,23 @@ SPHINXOPTS ?=
SPHINXBUILD ?= sphinx-build
SOURCEDIR = .
BUILDDIR = _build
+DESTDIR = final
# Put it first so that "make" without argument is like "make help".
help:
@$(SPHINXBUILD) -M help "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)
-.PHONY: help Makefile.sphinx
+.PHONY: help Makefile.sphinx clean publish
+
+publish: Makefile.sphinx html singlehtml
+ rm -rf $(BUILDDIR)/$(DESTDIR)/
+ mkdir -p $(BUILDDIR)/$(DESTDIR)/
+ cp -r $(BUILDDIR)/html/* $(BUILDDIR)/$(DESTDIR)/
+ cp $(BUILDDIR)/singlehtml/index.html $(BUILDDIR)/$(DESTDIR)/singleindex.html
+ sed -i -e 's@index.html#@singleindex.html#@g' $(BUILDDIR)/$(DESTDIR)/singleindex.html
+
+clean:
+ @rm -rf $(BUILDDIR)
# Catch-all target: route all unknown targets to Sphinx using the new
# "make mode" option. $(O) is meant as a shortcut for $(SPHINXOPTS).