summaryrefslogtreecommitdiffstats
path: root/doc
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-07-01 23:29:02 +0000
committerChris Larson <clarson@kergoth.com>2004-07-01 23:29:02 +0000
commitaa6c133778eef78ec3526dd4004187d8950a83a5 (patch)
tree3eaa4a2705b08a57bac8d5cbaeeef169450f4779 /doc
parent66e912e920d76890be2feb6ebbb013af2a77de0e (diff)
downloadbitbake-aa6c133778eef78ec3526dd4004187d8950a83a5.tar.gz
Delete: doc/DEVEL
Diffstat (limited to 'doc')
-rw-r--r--doc/DEVEL54
1 files changed, 0 insertions, 54 deletions
diff --git a/doc/DEVEL b/doc/DEVEL
deleted file mode 100644
index b36f663c8..000000000
--- a/doc/DEVEL
+++ /dev/null
@@ -1,54 +0,0 @@
-OpenEmbedded Developer Documentation
---
-
-How to add the build of a package to OpenEmbedded
-(henceforth known as "OE") in a few easy steps!
-
-First, you'll want to create the .oe.
- vi content/packagename_version.oe
- :wq
-
-(Note the underscore separating the packagename and the version.)
-
-Next, we need to add some content. First, define the
-"SRC_URI" variable to point to the upstream source tarball.
- SRC_URI:=${GNU_MIRROR}/ncurses/ncurses-5.3.tar.gz
-
-Then, we need to tell the system what will be extracted by
-that tarball:
- S=${WORKDIR}/${P}
-
-(Note: "P" defaults to ${PN}-${PV}, which is package name,
-and package version, respectively.)
-(Also note that S=${WORKDIR}/${P} is automatically set, so you
-just need to override, if the package extracts into another directory.)
-
-Finally, we need to make some decisions on how to build this.
-Take a look at the sources. If you see a 'configure.in',
-or 'configure.ac', this is an autoconf/automake based buildsystem.
-In this case, you're nearly done!
-
-Simply tell the buildsystem that:
- inherit autotools
-
-And attempt a build!
- oebuild content/packagename_version.oe
-
-If the build either is not autotools based, or deviates from it in
-any way, you can override any of the steps. For example:
-
- do_compile () {
- touch blahblah
- oe_runmake all
- }
-
-or
-
- do_install () {
- oe_runmake 'PREFIX=${D}' install
- }
-
-And so on. See $OEDIR/bin/classes/base.oeclass for an idea
-as to what tasks exist by default, and what their default behaviors are.
-The system will automatically assume that your .oe inherits base, in addition
-to whatever oeclasses you inherit manually.