aboutsummaryrefslogtreecommitdiffstats
path: root/doc/Makefile
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-11 17:38:18 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-11 17:41:43 +0100
commit452a62ae0c2793e281d6769fd3e45500a74898d6 (patch)
tree00b7591932ca89c39ae98689a73ef0edba911579 /doc/Makefile
parentbb4980c63db386ce7d30d9a6b86e9f3861b3bc3a (diff)
downloadbitbake-452a62ae0c2793e281d6769fd3e45500a74898d6.tar.gz
doc: Rename user-manual -> bitbake-user-manual
This manual gets combined with other manuals and in that context, it helps a lot if its seen as the Bitbake User Manual. Renames are a pain but this is worthwhile so that other docs can correctly be combined with this one. This also clarifies things like google search results which is helpful. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'doc/Makefile')
-rw-r--r--doc/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/doc/Makefile b/doc/Makefile
index 6b2af6732..8e98c57eb 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -18,21 +18,21 @@
#
# Examples:
#
-# make DOC=user-manual
-# make pdf DOC=user-manual
+# make DOC=bitbake-user-manual
+# make pdf DOC=bitbake-user-manual
#
# The first example generates the HTML and PDF versions of the User Manual.
# The second example generates the HTML version only of the User Manual.
#
-ifeq ($(DOC),user-manual)
-XSLTOPTS = --stringparam html.stylesheet user-manual-style.css \
+ifeq ($(DOC),bitbake-user-manual)
+XSLTOPTS = --stringparam html.stylesheet bitbake-user-manual-style.css \
--stringparam chapter.autolabel 1 \
--stringparam section.autolabel 1 \
--stringparam section.label.includes.component.label 1 \
--xinclude
ALLPREQ = html pdf tarball
-TARFILES = user-manual-style.css user-manual.html user-manual.pdf figures/bitbake-title.png
+TARFILES = bitbake-user-manual-style.css bitbake-user-manual.html bitbake-user-manual.pdf figures/bitbake-title.png
MANUALS = $(DOC)/$(DOC).html $(DOC)/$(DOC).pdf
FIGURES = figures
STYLESHEET = $(DOC)/*.css
@@ -48,7 +48,7 @@ XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
all: $(ALLPREQ)
pdf:
-ifeq ($(DOC),user-manual)
+ifeq ($(DOC),bitbake-user-manual)
@echo " "
@echo "********** Building."$(DOC)
@echo " "
@@ -56,7 +56,7 @@ ifeq ($(DOC),user-manual)
endif
html:
-ifeq ($(DOC),user-manual)
+ifeq ($(DOC),bitbake-user-manual)
# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
@echo " "
@echo "******** Building "$(DOC)