aboutsummaryrefslogtreecommitdiffstats
path: root/classes/base.bbclass
diff options
context:
space:
mode:
authorMasahiro Yamada <masahiroy@kernel.org>2019-12-22 16:09:14 +0900
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-28 23:50:40 +0000
commita8e7e913407d5c381fd817689bab19208919f86e (patch)
treebd8144f3b6fd50caf990b94ced1e990de9a4da1c /classes/base.bbclass
parente1a2a0e29a75dead3426ae083387181ad52da91f (diff)
downloadbitbake-a8e7e913407d5c381fd817689bab19208919f86e.tar.gz
base.bbclass: fix 'python should use 4 spaces indentation' warnings
Even if there are not so many users of base.bbclass bundled in bitbake, it is helpful as sample code at least. If this base.bbclass is used, bitbake emits the following warnings: WARNING: python should use 4 spaces indentation, but found tabs in base.bbclass, line 41 WARNING: python should use 4 spaces indentation, but found tabs in base.bbclass, line 42 WARNING: python should use 4 spaces indentation, but found tabs in base.bbclass, line 43 WARNING: python should use 4 spaces indentation, but found tabs in base.bbclass, line 44 WARNING: python should use 4 spaces indentation, but found tabs in base.bbclass, line 45 WARNING: python should use 4 spaces indentation, but found tabs in base.bbclass, line 46 WARNING: python should use 4 spaces indentation, but found tabs in base.bbclass, line 47 WARNING: python should use 4 spaces indentation, but found tabs in base.bbclass, line 53 WARNING: python should use 4 spaces indentation, but found tabs in base.bbclass, line 54 WARNING: python should use 4 spaces indentation, but found tabs in base.bbclass, line 55 WARNING: python should use 4 spaces indentation, but found tabs in base.bbclass, line 56 WARNING: python should use 4 spaces indentation, but found tabs in base.bbclass, line 63 WARNING: python should use 4 spaces indentation, but found tabs in base.bbclass, line 64 Let's fix the indentation as suggested. While I was touching these lines, I also fixed "isnt" into "isn't" in the comment line. Signed-off-by: Masahiro Yamada <masahiroy@kernel.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'classes/base.bbclass')
-rw-r--r--classes/base.bbclass26
1 files changed, 13 insertions, 13 deletions
diff --git a/classes/base.bbclass b/classes/base.bbclass
index 08441fe16..18093961a 100644
--- a/classes/base.bbclass
+++ b/classes/base.bbclass
@@ -38,30 +38,30 @@ bbfatal() {
addtask showdata
do_showdata[nostamp] = "1"
python do_showdata() {
- import sys
- # emit variables and shell functions
- bb.data.emit_env(sys.__stdout__, d, True)
- # emit the metadata which isnt valid shell
- for e in bb.data.keys(d):
- if d.getVarFlag(e, 'python', False):
- bb.plain("\npython %s () {\n%s}" % (e, d.getVar(e)))
+ import sys
+ # emit variables and shell functions
+ bb.data.emit_env(sys.__stdout__, d, True)
+ # emit the metadata which isn't valid shell
+ for e in bb.data.keys(d):
+ if d.getVarFlag(e, 'python', False):
+ bb.plain("\npython %s () {\n%s}" % (e, d.getVar(e)))
}
addtask listtasks
do_listtasks[nostamp] = "1"
python do_listtasks() {
- import sys
- for e in bb.data.keys(d):
- if d.getVarFlag(e, 'task', False):
- bb.plain("%s" % e)
+ import sys
+ for e in bb.data.keys(d):
+ if d.getVarFlag(e, 'task', False):
+ bb.plain("%s" % e)
}
addtask build
do_build[dirs] = "${TOPDIR}"
do_build[nostamp] = "1"
python base_do_build () {
- bb.note("The included, default BB base.bbclass does not define a useful default task.")
- bb.note("Try running the 'listtasks' task against a .bb to see what tasks are defined.")
+ bb.note("The included, default BB base.bbclass does not define a useful default task.")
+ bb.note("Try running the 'listtasks' task against a .bb to see what tasks are defined.")
}
EXPORT_FUNCTIONS do_clean do_mrproper do_build