summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2006-09-09 21:24:20 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2006-09-09 21:24:20 +0000
commitfdb2e3ced1a00dc029c69878a7afb63bf4643797 (patch)
tree5cf3bfede36aa3eb2e8de2bfdb0d0c08d083f585 /bin
parentbe966771286d0d43c9bb398406109170849ba13a (diff)
downloadbitbake-fdb2e3ced1a00dc029c69878a7afb63bf4643797.tar.gz
Add bitbake -l option to specify debug domains to show
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake9
1 files changed, 9 insertions, 0 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 97baf9fc8..3ab8d7e3b 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -667,6 +667,11 @@ class BBCooker:
if self.configuration.debug:
bb.msg.set_debug_level(self.configuration.debug)
+ else:
+ bb.msg.set_debug_level(0)
+
+ if self.configuration.debug_domains:
+ bb.msg.set_debug_domains(self.configuration.debug_domains)
self.configuration.data = bb.data.init()
@@ -959,9 +964,13 @@ Default BBFILES are the .bb files in the current directory.""" )
parser.add_option( "-g", "--graphviz", help = "emit the dependency trees of the specified packages in the dot syntax",
action = "store_true", dest = "dot_graph", default = False )
+
parser.add_option( "-I", "--ignore-deps", help = """Stop processing at the given list of dependencies when generating dependency graphs. This can help to make the graph more appealing""",
action = "append", dest = "ignored_dot_deps", default = [] )
+ parser.add_option( "-l", "--log-domains", help = """Show debug logging for the specified logging domains""",
+ action = "append", dest = "debug_domains", default = [] )
+
options, args = parser.parse_args( sys.argv )