aboutsummaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2008-12-06 13:13:58 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2008-12-06 13:13:58 +0000
commitfa8cb50e731c86207cc0f6b748925db4c6e14195 (patch)
tree81f8e86e0a50af4e9ab7fe7366fbf12163057c6c /bin
parent322861718500f16e29f1b92dfe956c1c76e84480 (diff)
downloadbitbake-fa8cb50e731c86207cc0f6b748925db4c6e14195.tar.gz
bin/bitbake: Fix cooker log handling after recent changes
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake12
1 files changed, 4 insertions, 8 deletions
diff --git a/bin/bitbake b/bin/bitbake
index b699afbab..f5eb29a97 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -133,17 +133,13 @@ Default BBFILES are the .bb files in the current directory.""" )
# of the UIs (e.g. for DISPLAY, etc.)
bb.utils.clean_environment()
- cooker.parseConfiguration()
+ cooker.parseCommandLine()
host = cooker.server.host
port = cooker.server.port
- # Save a logfile for cooker somewhere
- t = bb.data.getVar('TMPDIR', cooker.configuration.data, True)
- if not t:
- bb.msg.fatal(bb.msg.domain.Build, "TMPDIR not set")
- t = os.path.join(t, "cooker")
- bb.mkdirhier(t)
- cooker_logfile = "%s/log.cooker.%s" % (t, str(os.getpid()))
+ # Save a logfile for cooker into the current working directory. When the
+ # server is daemonized this logfile will be truncated.
+ cooker_logfile = os.path.join (os.getcwd(), "cooker.log")
daemonize.createDaemon(cooker.serve, cooker_logfile)
del cooker