aboutsummaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2011-07-02 23:15:30 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-05 13:35:53 +0100
commitf5ba7c795df7cbd58124e35970ddc5bd84cbfb8e (patch)
tree64c4675bf8dc6efd2db47b00e9e2b644932d25de /bin
parentedacf98cceb2fe1275042595d3fce6822fa411ca (diff)
downloadbitbake-f5ba7c795df7cbd58124e35970ddc5bd84cbfb8e.tar.gz
bitbake/cooker, bitbake-layers: show the .bbappend files that matches no existing .bb recipe
This patch moves the logic of show_appends_with_no_recipes from bitbake-layers into bitbake. By default, a fatal message is printed; we can also define a variable BB_DANGLINGAPPENDS_WARNONLY to make the message only a warning(the variables could be defined in conf/local.conf with a value "yes", "true" or "1"). Signed-off-by: Dexuan Cui <dexuan.cui@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake-layers21
1 files changed, 1 insertions, 20 deletions
diff --git a/bin/bitbake-layers b/bin/bitbake-layers
index dfbdb7032..5abf26cfb 100755
--- a/bin/bitbake-layers
+++ b/bin/bitbake-layers
@@ -55,7 +55,7 @@ class Commands(cmd.Cmd):
def prepare_cooker(self):
sys.stderr.write("Parsing recipes..")
- logger.setLevel(logging.ERROR)
+ logger.setLevel(logging.WARNING)
try:
while self.cooker.state in (state.initial, state.parsing):
@@ -156,8 +156,6 @@ class Commands(cmd.Cmd):
self.show_appends_for_skipped()
- self.show_appends_with_no_recipes()
-
def show_appends_for_pn(self, pn):
filenames = self.cooker_data.pkg_pn[pn]
@@ -204,23 +202,6 @@ class Commands(cmd.Cmd):
notappended.append(basename)
return appended, notappended
- def show_appends_with_no_recipes(self):
- recipes = set(os.path.basename(f)
- for f in self.cooker_data.pkg_fn.iterkeys())
- recipes |= set(os.path.basename(f)
- for f in self.cooker.skiplist.iterkeys())
- appended_recipes = self.cooker_data.appends.iterkeys()
- appends_without_recipes = [self.cooker_data.appends[recipe]
- for recipe in appended_recipes
- if recipe not in recipes]
- if appends_without_recipes:
- appendlines = (' %s' % append
- for appends in appends_without_recipes
- for append in appends)
- logger.warn('No recipes available for:\n%s',
- '\n'.join(appendlines))
- self.returncode |= 4
-
def do_EOF(self, line):
return True