aboutsummaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2007-08-18 15:35:52 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2007-08-18 15:35:52 +0000
commitc8d0e6df69d6b49aa80c9cde5557b5a3c12a88dc (patch)
tree4dd44a3f544387032899178daf47bc154f1f755d /bin
parent39e7932136753be7eb3de65b813b7a8f2d0396de (diff)
downloadbitbake-c8d0e6df69d6b49aa80c9cde5557b5a3c12a88dc.tar.gz
bin/bitbake: Fix execution order
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake7
1 files changed, 4 insertions, 3 deletions
diff --git a/bin/bitbake b/bin/bitbake
index a2fabf7ff..c3af2cbac 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -114,6 +114,10 @@ Default BBFILES are the .bb files in the current directory.""" )
configuration.pkgs_to_build = []
configuration.pkgs_to_build.extend(args[1:])
+ cooker = bb.cooker.BBCooker(configuration)
+ host = cooker.server.host
+ port = cooker.server.port
+
# Save a logfile for cooker somewhere
t = bb.data.getVar('TMPDIR', cooker.configuration.data, True)
if not t:
@@ -122,9 +126,6 @@ Default BBFILES are the .bb files in the current directory.""" )
bb.mkdirhier(t)
cooker_logfile = "%s/log.cooker.%s" % (t, str(os.getpid()))
- cooker = bb.cooker.BBCooker(configuration)
- host = cooker.server.host
- port = cooker.server.port
daemonize.createDaemon(cooker.serve, cooker_logfile)
del cooker