aboutsummaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2008-12-06 11:50:02 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2008-12-06 11:50:02 +0000
commit8c112e0aa9c8e12e1560a8894d5dfecd370a6bcc (patch)
treed7fdee51540754d25c985307796f3a69cca94e8f /bin
parent0bc7836736f0087d91ac72ea3bbf9cc608687881 (diff)
downloadbitbake-8c112e0aa9c8e12e1560a8894d5dfecd370a6bcc.tar.gz
Add tryaltconfigs option to control whether bitbake trys using alternative providers to fulfil failed dependencies. It defaults to off, changing the default since this behaviour confuses many users and isn't often useful (from Poky).
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake3
1 files changed, 3 insertions, 0 deletions
diff --git a/bin/bitbake b/bin/bitbake
index ef453a58a..525150e5e 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -69,6 +69,9 @@ Default BBFILES are the .bb files in the current directory.""" )
parser.add_option( "-k", "--continue", help = "continue as much as possible after an error. While the target that failed, and those that depend on it, cannot be remade, the other dependencies of these targets can be processed all the same.",
action = "store_false", dest = "abort", default = True )
+ parser.add_option( "-a", "--tryaltconfigs", help = "continue with builds by trying to use alternative providers where possible.",
+ action = "store_true", dest = "tryaltconfigs", default = False )
+
parser.add_option( "-f", "--force", help = "force run of specified cmd, regardless of stamp status",
action = "store_true", dest = "force", default = False )