aboutsummaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2009-10-17 19:02:09 +0100
committerRichard Purdie <rpurdie@rpsys.net>2009-10-17 19:22:52 +0100
commit6252c7d5c1c7123d16fc3c7db2edc6751420f12c (patch)
treea906dd23c74dd626152ac097a0e18c184b7da69d /bin
parentc4b18ff5e26e4f52336fe1fc5a0e215e4d4d9aaa (diff)
downloadbitbake-6252c7d5c1c7123d16fc3c7db2edc6751420f12c.tar.gz
Add a compare-versions command which returns whether the SRCREV versions have changed since bitbake was last run (from Poky)
Signed-off-by: Richard Purdie <rpurdie@rpsys.net>
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake3
1 files changed, 3 insertions, 0 deletions
diff --git a/bin/bitbake b/bin/bitbake
index f02630b10..b2edcf48f 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -135,6 +135,9 @@ Default BBFILES are the .bb files in the current directory.""" )
parser.add_option( "-u", "--ui", help = "userinterface to use",
action = "store", dest = "ui")
+ parser.add_option( "", "--revisions-changed", help = "Set the exit code depending on whether upstream floating revisions have changed or not",
+ action = "store_true", dest = "revisions_changed", default = False )
+
options, args = parser.parse_args(sys.argv)
configuration = BBConfiguration(options)