aboutsummaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-01-14 18:52:43 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-01-14 18:52:43 +0000
commit5c845093fc548cd660d4bf61e8ade9d1c7f2609a (patch)
treea3a9491b55e64d4201d556fa07a5cb5491f08461 /bin
parent08ed701a6ce0a6f49a0eb44e8818612c7b68ebc5 (diff)
downloadbitbake-5c845093fc548cd660d4bf61e8ade9d1c7f2609a.tar.gz
Solidify server class creation
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake10
1 files changed, 5 insertions, 5 deletions
diff --git a/bin/bitbake b/bin/bitbake
index b2edcf48f..f03baaaa6 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -144,7 +144,11 @@ Default BBFILES are the .bb files in the current directory.""" )
configuration.pkgs_to_build = []
configuration.pkgs_to_build.extend(args[1:])
- cooker = bb.cooker.BBCooker(configuration)
+ # Save a logfile for cooker into the current working directory. When the
+ # server is daemonized this logfile will be truncated.
+ cooker_logfile = os.path.join (os.getcwd(), "cooker.log")
+
+ cooker = bb.cooker.BBCooker(configuration, bb.server.xmlrpc)
# Clear away any spurious environment variables. But don't wipe the
# environment totally. This is necessary to ensure the correct operation
@@ -155,10 +159,6 @@ Default BBFILES are the .bb files in the current directory.""" )
host = cooker.server.host
port = cooker.server.port
- # Save a logfile for cooker into the current working directory. When the
- # server is daemonized this logfile will be truncated.
- cooker_logfile = os.path.join (os.getcwd(), "cooker.log")
-
daemonize.createDaemon(cooker.serve, cooker_logfile)
del cooker