aboutsummaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-14 12:30:27 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-14 12:35:38 +0000
commit3a1b75037fe1e5282ffd40b037e93353405faa45 (patch)
treebed7e6e0d22a098224305331340cbcdd2ce84951 /bin
parentc6211291ae07410832031a5274690437cc2b09a6 (diff)
downloadbitbake-3a1b75037fe1e5282ffd40b037e93353405faa45.tar.gz
bin/bitbake, bb/__init__: Move BBDEBUG handling to bin/bitbake
The method this older code was accessing doesn't exist. A library shouldn't be changing behaviour based on the environment anyway when sepcific function calls exist to correctly setup the logging. Fix the crash if BBDEBUG was used by moving the code to bin/bitbake. [YOCTO #3319] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake5
1 files changed, 5 insertions, 0 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 324ee4fa5..e86d59bd6 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -214,6 +214,11 @@ Default BBFILES are the .bb files in the current directory.""")
if configuration.bind and configuration.servertype != "xmlrpc":
sys.exit("FATAL: If '-B' or '--bind' is defined, we must set the servertype as 'xmlrpc'.\n")
+ if "BBDEBUG" in os.environ:
+ level = int(os.environ["BBDEBUG"])
+ if level > configuration.debug:
+ configuration.debug = level
+
bb.msg.init_msgconfig(configuration.verbose, configuration.debug,
configuration.debug_domains)