aboutsummaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-12-10 02:19:44 +0000
committerChris Larson <clarson@kergoth.com>2004-12-10 02:19:44 +0000
commit16792155360c96af2ce4e83f94653ee70899a9ef (patch)
treee98c26e4bd4786f95b0a59cedc0c6376b13bb4e5 /bin
parentdc320341163f7a52209af0c87a110e33370ecbb3 (diff)
downloadbitbake-16792155360c96af2ce4e83f94653ee70899a9ef.tar.gz
Make bbread use bb.make.load_bbfile() rather than calling handle on the .bb itself.
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bbread9
1 files changed, 5 insertions, 4 deletions
diff --git a/bin/bbread b/bin/bbread
index b496e7677..99e5013b7 100755
--- a/bin/bbread
+++ b/bin/bbread
@@ -19,19 +19,20 @@
import sys, copy, os
sys.path.append(os.path.join(os.path.dirname(os.path.dirname(sys.argv[0])), 'lib'))
-import bb, bb.parse, bb.build
+import bb, bb.parse, bb.build, bb.make
d = bb.data.init()
try:
- d = bb.parse.handle(os.path.join('conf', 'bitbake.conf'), d)
+ bb.make.cfg = bb.parse.handle(os.path.join('conf', 'bitbake.conf'), d)
except IOError, e:
bb.fatal("Unable to read conf/bitbake.conf: %s" % e)
if len(sys.argv) == 2:
+ bbfile = sys.argv[1]
try:
- d = bb.parse.handle(sys.argv[1], d)
+ d, fromCache = bb.make.load_bbfile(bbfile)
except IOError, e:
- bb.fatal("Unable to read %s: %s" % (sys.argv[1], e))
+ bb.fatal("Unable to read %s: %s" % (bbfile, e))
except Exception, e:
bb.fatal("%s" % e)