aboutsummaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2008-12-06 12:27:37 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2008-12-06 12:27:37 +0000
commit080eb8764a5a6ec3d7522ef8ec45b58547196d3e (patch)
treed0f8598ae480c389ee1ca9dc2d2360e2948360c3 /bin
parent92a1332420012712b19d5b080aa0bacb6bace4d1 (diff)
downloadbitbake-080eb8764a5a6ec3d7522ef8ec45b58547196d3e.tar.gz
utils.py: Add clean_environment() function and call where appropriate (from Poky)
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake13
1 files changed, 4 insertions, 9 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 525150e5e..0a0ecfc4e 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -144,15 +144,10 @@ Default BBFILES are the .bb files in the current directory.""" )
cooker = bb.cooker.BBCooker(configuration)
- # Optionally clean up the environment
- if 'BB_PRESERVE_ENV' not in os.environ:
- if 'BB_ENV_WHITELIST' in os.environ:
- good_vars = os.environ['BB_ENV_WHITELIST'].split()
- else:
- good_vars = bb.utils.preserved_envvars_list()
- if 'BB_ENV_EXTRAWHITE' in os.environ:
- good_vars.extend(os.environ['BB_ENV_EXTRAWHITE'].split())
- bb.utils.filter_environment(good_vars)
+ # Clear away any spurious environment variables. But don't wipe the
+ # environment totally. This is necessary to ensure the correct operation
+ # of the UIs (e.g. for DISPLAY, etc.)
+ bb.utils.clean_environment()
cooker.parseConfiguration()
host = cooker.server.host