summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-06-21 18:28:46 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-22 13:59:50 +0100
commit9ab269410ef5cd4753fe11ec74759f421685bb7b (patch)
tree00a3f73f1cd535b8a9b23594b7a8237c0e9ec7e9 /bin
parent2bab2cc3ffe67ee2a308074a6e4c2c7be5636d2f (diff)
downloadbitbake-9ab269410ef5cd4753fe11ec74759f421685bb7b.tar.gz
bitbake: tweak help text for -C slightly
What is specified is a command (or "cmd" as in the help text for -f) rather than a task - i.e. you specify compile, not do_compile, so change the sentence to reflect that and reorder it slightly so it makes sense. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake2
1 files changed, 1 insertions, 1 deletions
diff --git a/bin/bitbake b/bin/bitbake
index f23673fdf..e55a53805 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -118,7 +118,7 @@ Default BBFILES are the .bb files in the current directory.""")
parser.add_option("-c", "--cmd", help = "Specify task to execute. Note that this only executes the specified task for the providee and the packages it depends on, i.e. 'compile' does not implicitly call stage for the dependencies (IOW: use only if you know what you are doing). Depending on the base.bbclass a listtasks tasks is defined and will show available tasks",
action = "store", dest = "cmd")
- parser.add_option("-C", "--clear-stamp", help = "Invalidate the specified stamp for a task such as 'compile' and run the default task for the specified target(s)",
+ parser.add_option("-C", "--clear-stamp", help = "Invalidate the stamp for the specified cmd such as 'compile' and run the default task for the specified target(s)",
action = "store", dest = "invalidate_stamp")
parser.add_option("-r", "--read", help = "read the specified file before bitbake.conf",