summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-31 14:49:43 +0100
committerChris Larson <chris_larson@mentor.com>2010-12-29 23:51:07 -0700
commit10c771f2f961c61628b283e9962e8aa6df73eab1 (patch)
tree728856d2da564421c34696c6606b22d2824c52cb /bin
parentedbdf6fc89d915f06b62c5a06726e0e46a940d2e (diff)
downloadbitbake-10c771f2f961c61628b283e9962e8aa6df73eab1.tar.gz
Implement task signatures
Includes functionality to find out what changes between two different signature data dumps. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com> Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake3
-rwxr-xr-xbin/bitbake-diffsigs12
2 files changed, 15 insertions, 0 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 63b1d1d12..e14c017c1 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -135,6 +135,9 @@ Default BBFILES are the .bb files in the current directory.""")
parser.add_option("-n", "--dry-run", help = "don't execute, just go through the motions",
action = "store_true", dest = "dry_run", default = False)
+ parser.add_option("-S", "--dump-signatures", help = "don't execute, just dump out the signature construction information",
+ action = "store_true", dest = "dump_signatures", default = False)
+
parser.add_option("-p", "--parse-only", help = "quit after parsing the BB files (developers only)",
action = "store_true", dest = "parse_only", default = False)
diff --git a/bin/bitbake-diffsigs b/bin/bitbake-diffsigs
new file mode 100755
index 000000000..5eb77ce59
--- /dev/null
+++ b/bin/bitbake-diffsigs
@@ -0,0 +1,12 @@
+#!/usr/bin/env python
+import os
+import sys
+import warnings
+sys.path.insert(0, os.path.join(os.path.dirname(os.path.dirname(sys.argv[0])), 'lib'))
+
+import bb.siggen
+
+if len(sys.argv) > 2:
+ bb.siggen.compare_sigfiles(sys.argv[1], sys.argv[2])
+else:
+ bb.siggen.dump_sigfile(sys.argv[1])