aboutsummaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-12-22 23:04:35 +0000
committerChris Larson <clarson@kergoth.com>2004-12-22 23:04:35 +0000
commit93224b3c62cefc6e97b3f813e2dd731cdc878e4d (patch)
tree8c97023fcc9a5f4d84817ddec92cb35147bb2b7b /bin/bitbake
parent5854acd91e2cecbbfa9cc1b8d6c45c3e55820b6e (diff)
downloadbitbake-93224b3c62cefc6e97b3f813e2dd731cdc878e4d.tar.gz
Handle the parse only cmdline option when using --buildfile.
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake4
1 files changed, 4 insertions, 0 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 1acb33563..3deb4e6d5 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -547,6 +547,10 @@ def executeOneBB( fn ):
except IOError:
bb.fatal("Unable to open %s" % fn)
+ if make.options.parse_only:
+ print "Requested parsing .bb files only. Exiting."
+ sys.exit(0)
+
name = bb.data.getVar('PN', d, 1)
bb.event.fire(bb.event.PkgStarted(name, d))
try: