summaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
authorJason Wessel <jason.wessel@windriver.com>2012-09-17 17:43:17 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-24 15:26:09 +0100
commit440e479f3e248482c38c149643403c6907ac7034 (patch)
tree8a68a0a804e511a46cd50a38768a56e50bff1c67 /bin/bitbake
parent1270a07713e2a6c6e6fadcc61b785aebc99ae17b (diff)
downloadbitbake-440e479f3e248482c38c149643403c6907ac7034.tar.gz
runqueue: Add --no-setscene to skip all setscene tasks
Mainly intended for the purpose of debugging or forcing builds from source, the --no-setscene will prevent any setscene tasks from running. Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake2
1 files changed, 2 insertions, 0 deletions
diff --git a/bin/bitbake b/bin/bitbake
index ed2ff0630..8c4602425 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -174,6 +174,8 @@ Default BBFILES are the .bb files in the current directory.""")
parser.add_option("-B", "--bind", help = "The name/address for the bitbake server to bind to",
action = "store", dest = "bind", default = False)
+ parser.add_option("", "--no-setscene", help = "Do not run any setscene tasks, forces builds",
+ action = "store_true", dest = "nosetscene", default = False)
options, args = parser.parse_args(sys.argv)
configuration = BBConfiguration(options)