summaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-04-15 08:45:15 -0700
committerChris Larson <chris_larson@mentor.com>2010-04-15 08:54:07 -0700
commitf936f1c0edf70860ea0f39ec1a500ba43b56f289 (patch)
tree42d7138b0448733bff53634a9e205105b6f5f27d /bin/bitbake
parent8f4b7b10f8740a41c085beeca5105f15204b0979 (diff)
downloadbitbake-f936f1c0edf70860ea0f39ec1a500ba43b56f289.tar.gz
Move the python version check into the python package
This ensures the check is run for anyone using the package, including setup.py, though it's sad that it's necessary, since all it really wants is __version__. Ideally, we'd avoid the version check entirely in favor of checking for functionality, but that's rather difficult with language constructs like context managers, so this'll do for now. Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake6
1 files changed, 1 insertions, 5 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 6edf4b732..7c484a2f7 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -22,12 +22,8 @@
# with this program; if not, write to the Free Software Foundation, Inc.,
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-import sys
-if sys.version_info < (2, 6, 0):
- print "Sorry, python 2.6.0 or later is required for this version of bitbake"
- sys.exit(1)
-
import os
+import sys
sys.path.insert(0, os.path.join(os.path.dirname(os.path.dirname(sys.argv[0])),
'lib'))